I.C.E. (Audio) & Electrical Upgrades Post all your I.C.E. (In Car Entertainment) and wiring questions here (Audio, video etc.)

2003 instrument panel on&off problem

Old 10-30-2008
  #1  
PAL
Registered!!
Thread Starter
 
Join Date: Oct 2008
Posts: 3
Rep Power: 0
PAL is an unknown quantity at this point
Post 2003 instrument panel on&off problem

I have intermittent "on & off" problem with the temperature, speedometer, tacometer, mileage counter and petrol gauge. When it is "on", everything is working fine. When it is "off", the gauges are "down" and mileage meter = blank. When it is "on" again, the mileage meter shows last registered number.
Other indicators like "door ajar", "seat-belt", etc are always working.

The service center advisor insists that the panel needs replacement with a new one. He checked my panel that there is power supply but panel not working. When he removed my panel and put in a temporary panel to test, the temporary panel works. When I asked if it means the "on&off" problem will be resolved once & for all with the new panel, he said "most likely unless it is some obscure wiring problem". He can't tell which gauge is faulty; said my panel problem is a very rare problem.

Anyone faced this problem ? How was it fixed ?
PAL is offline  
Old 10-30-2008
  #2  
Premium Member
Hey! Look At Me!! I'm a Supporting Member!!
iTrader: (95)
 
Join Date: Sep 2002
Location: NV
Age: 38
Posts: 51,322
Rep Power: 727
gearbox has a reputation beyond reputegearbox has a reputation beyond reputegearbox has a reputation beyond reputegearbox has a reputation beyond reputegearbox has a reputation beyond reputegearbox has a reputation beyond reputegearbox has a reputation beyond reputegearbox has a reputation beyond reputegearbox has a reputation beyond reputegearbox has a reputation beyond reputegearbox has a reputation beyond repute
Re: 2003 instrument panel on&off problem

what kind of car? most newer cars ive seen turn off completely and drop all the needles down.
gearbox is offline  
Old 10-31-2008
  #3  
PAL
Registered!!
Thread Starter
 
Join Date: Oct 2008
Posts: 3
Rep Power: 0
PAL is an unknown quantity at this point
Re: 2003 instrument panel on&off problem

The "on&off" problem occurs when the engine is on & and I am driving. That's why it is irritating. Suddenly, you don't see yr speed, RPM/petrol at "zero" and mileage = blank. It comes back "on" by itself. There is no noticeable "trigger" like if it goes "off" when I turn on the radio or something like that. And apart from a new battery replacement (a few weeks before this On&off problem), I have not touched the electricals in the car.
PAL is offline  
Old 10-31-2008
  #4  
Premium Member
Hey! Look At Me!! I'm a Supporting Member!!
iTrader: (95)
 
Join Date: Sep 2002
Location: NV
Age: 38
Posts: 51,322
Rep Power: 727
gearbox has a reputation beyond reputegearbox has a reputation beyond reputegearbox has a reputation beyond reputegearbox has a reputation beyond reputegearbox has a reputation beyond reputegearbox has a reputation beyond reputegearbox has a reputation beyond reputegearbox has a reputation beyond reputegearbox has a reputation beyond reputegearbox has a reputation beyond reputegearbox has a reputation beyond repute
Re: 2003 instrument panel on&off problem

almost sounds like a loose wire in the harness, or a bad ground. unplug the connectors and examine both the gauge cluster pins and pull the wires to see if any are loose.
gearbox is offline  
Old 11-06-2008
  #5  
PAL
Registered!!
Thread Starter
 
Join Date: Oct 2008
Posts: 3
Rep Power: 0
PAL is an unknown quantity at this point
Re: 2003 instrument panel on&off problem

I took my car to an auto electrician and give him your advice to check the harness, etc. The auto electrician still said that he is unable to find the problem and insists it is the whole instrument panel faulty. He asked me to replace it. And the intermittent problem which used to be "off" for a few minutes/seconds and "on" by itself again is lately getting worst. It is like "off" more than "on". When it is "on", I see a flash with the mileage number (still last "on" correct number). Then <10seconds later, it is "off".

Pls help give more advice. Is it really that the whole instrument panel is faulty OR still fixable problem ? I don't understand if the whole panel is with faulty circuit, why is it still tracking mileage number (last "on" number), all needles working well ? It is so frustrating when driving...
PAL is offline  
Old 11-06-2008
  #6  
30 Years Driving Japanese Autos
iTrader: (1)
 
CraigW's Avatar
 
Join Date: Mar 2005
Posts: 4,849
Rep Power: 221
CraigW is a glorious beacon of lightCraigW is a glorious beacon of lightCraigW is a glorious beacon of lightCraigW is a glorious beacon of lightCraigW is a glorious beacon of lightCraigW is a glorious beacon of lightCraigW is a glorious beacon of light
Re: 2003 instrument panel on&off problem

If re-seating the connectors on the cluster module did not solve the problem... Then, I would have to agree with what he said. The fact that the test cluster works o.k. is also a good informative test idea that he performed.

You can get one from a junkyard (match year, body style and trim level for plug and play) The problem will be the mileage shown will be from the other cars total mileage, Could be lower could be higher.
CraigW is offline  
Old 11-09-2008
  #7  
Member
Hey! Look At Me!! I'm a Supporting Member!!
iTrader: (2)
 
Join Date: Jun 2008
Location: GTA, Ontario
Age: 30
Posts: 171
Rep Power: 0
Albertross has a reputation beyond reputeAlbertross has a reputation beyond reputeAlbertross has a reputation beyond reputeAlbertross has a reputation beyond reputeAlbertross has a reputation beyond reputeAlbertross has a reputation beyond reputeAlbertross has a reputation beyond reputeAlbertross has a reputation beyond reputeAlbertross has a reputation beyond reputeAlbertross has a reputation beyond reputeAlbertross has a reputation beyond repute
Re: 2003 instrument panel on&off problem

I've had this problem.
It's the cluster.
Buy yourself a new one.
Albertross is offline  
Old 02-01-2010
  #8  
Registered!!
 
Join Date: Feb 2010
Posts: 1
Rep Power: 0
R Mont is an unknown quantity at this point
Re: 2003 instrument panel on&off problem

Where would you recommend I buy the new cluster from, other than the dealer?
Are they easy to install?
R Mont is offline  
Old 02-01-2010
  #9  
Premium Member
Hey! Look At Me!! I'm a Supporting Member!!
iTrader: (95)
 
Join Date: Sep 2002
Location: NV
Age: 38
Posts: 51,322
Rep Power: 727
gearbox has a reputation beyond reputegearbox has a reputation beyond reputegearbox has a reputation beyond reputegearbox has a reputation beyond reputegearbox has a reputation beyond reputegearbox has a reputation beyond reputegearbox has a reputation beyond reputegearbox has a reputation beyond reputegearbox has a reputation beyond reputegearbox has a reputation beyond reputegearbox has a reputation beyond repute
Re: 2003 instrument panel on&off problem

ebay. pretty easy yeah. just be sure to find one with the same mileage as your car. and coupe/sedan have different lighting at night.
gearbox is offline  
Old 04-18-2015
  #10  
Registered!!
 
Join Date: Apr 2015
Posts: 3
Rep Power: 0
detonator29 is an unknown quantity at this point
Re: 2003 instrument panel on&off problem

I have a 2004 special edition (Canadian) with a 5 speed and have a very similar problem to what you described. The only difference is that the panel does not come on when I start the car, have never had it drop off while running. Did replacing the instrument cluster solve the problem? I have been hoping it is just a loose connection as it will sometimes come back on when driving and if I smack the dash above the instrument panel it will often come back on. Any help would be greatly appreciated!
detonator29 is offline  
Old 07-09-2015
  #11  
Registered!!
 
Join Date: Aug 2011
Posts: 308
Rep Power: 97
Thaik will become famous soon enoughThaik will become famous soon enough
Re: 2003 instrument panel on&off problem

I did a cluster swap.
From DX to LX 03-05.

Still has the same issue, but a bit different, it's more frequent, all warning lights seem to be working.
When the cluster is not working and by doing a cluster self diagnostic test, it works but only the working instruments.

As opposed to the old cluster, whenever it wouldn't work, self diagnostic test wouldn't work at all.

It seems to be a recurring issue with these clusters so probably it's the cluster itself isn't new, 200k kilometers on it, one from a recycling yard.
Thaik is offline  
Related Topics
Thread
Thread Starter
Honda Civic Forum
Replies
Last Post
S.Klinck
Canada Forsale/Trade eh?
1
02-10-2016 02:19 PM
S.Klinck
Vehicles for Sale/Wanted
1
06-11-2015 10:27 PM
beveragemp
I.C.E. (Audio) & Electrical Upgrades
10
05-25-2015 07:11 PM
trellex
Mechanical Problems/Vehicle Issues and Fix-it Forum
5
05-24-2015 04:39 PM
One_PeeJay
Parts for Sale
2
05-17-2015 05:31 PM


Thread Tools
Search this Thread
Quick Reply: 2003 instrument panel on&off problem


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.