amp protection problem. HELP! - Honda Civic Forum

Electrical, Wiring, and In Car Entertainment Electrical, Wiring and In Car Entertainment questions belong here.

amp protection problem. HELP!

Old 06-13-2007
  #1  
Registered!!
Thread Starter
iTrader: (11)
 
Join Date: Feb 2003
Location: SD, California, US
Posts: 897
Rep Power: 0
Hippiboy is an unknown quantity at this point
amp protection problem. HELP!

Lately i noticed that my amp will temporarely shut off when I turn up the volume. Then it will turn right back on. I also noticed that my protection light goes on when the amp turns off. Anyone know what is wrong or how i can fix this?

Right now i have a 1000 watt kicker amp with a 12 in L7 solobaric

Thanks
Hippiboy is offline  
Old 06-13-2007
  #2  
Registered!!
 
Stearic's Avatar
 
Join Date: Apr 2006
Location: Kansas
Age: 34
Posts: 98
Rep Power: 0
Stearic is an unknown quantity at this point
Re: amp protection problem. HELP!

You might have the gain on the amp turned up to much. I'd say try turning it down a bit and see how that works.
Stearic is offline  
Old 06-13-2007
  #3  
Registered!!
Thread Starter
iTrader: (11)
 
Join Date: Feb 2003
Location: SD, California, US
Posts: 897
Rep Power: 0
Hippiboy is an unknown quantity at this point
Re: amp protection problem. HELP!

Originally Posted by Stearic View Post
You might have the gain on the amp turned up to much. I'd say try turning it down a bit and see how that works.

i did turn it down. It is only set at the half way. I never had this problem when i first installed the system. I just dont get it....
Hippiboy is offline  
Old 06-13-2007
  #4  
Registered!!
 
christmaspie's Avatar
 
Join Date: Apr 2005
Location: Temecula, CA
Age: 34
Posts: 592
Rep Power: 176
christmaspie is a glorious beacon of lightchristmaspie is a glorious beacon of lightchristmaspie is a glorious beacon of lightchristmaspie is a glorious beacon of lightchristmaspie is a glorious beacon of lightchristmaspie is a glorious beacon of light
Re: amp protection problem. HELP!

Maybe need to upgrade the amp's connection to ground. Also might want to check the speaker's resistance make sure both voice coils are alright if it's a DVC.
christmaspie is offline  
Old 06-14-2007
  #5  
Administrator
Administrator
iTrader: (44)
 
electric130's Avatar
 
Join Date: Aug 2006
Location: Charlotte
Age: 40
Posts: 2,967
Rep Power: 204
electric130 has a reputation beyond reputeelectric130 has a reputation beyond reputeelectric130 has a reputation beyond reputeelectric130 has a reputation beyond reputeelectric130 has a reputation beyond reputeelectric130 has a reputation beyond reputeelectric130 has a reputation beyond reputeelectric130 has a reputation beyond reputeelectric130 has a reputation beyond reputeelectric130 has a reputation beyond reputeelectric130 has a reputation beyond repute
Re: amp protection problem. HELP!

what size wires are you running on the amp power, amp ground, and battery to chassis ground?
electric130 is offline  
Old 06-14-2007
  #6  
Registered!!
Thread Starter
iTrader: (11)
 
Join Date: Feb 2003
Location: SD, California, US
Posts: 897
Rep Power: 0
Hippiboy is an unknown quantity at this point
Re: amp protection problem. HELP!

Originally Posted by electric130 View Post
what size wires are you running on the amp power, amp ground, and battery to chassis ground?

im running 4 guage for the power and the ground. and 12 guage for the speaker.
Hippiboy is offline  
Old 06-14-2007
  #7  
Administrator
Administrator
iTrader: (44)
 
electric130's Avatar
 
Join Date: Aug 2006
Location: Charlotte
Age: 40
Posts: 2,967
Rep Power: 204
electric130 has a reputation beyond reputeelectric130 has a reputation beyond reputeelectric130 has a reputation beyond reputeelectric130 has a reputation beyond reputeelectric130 has a reputation beyond reputeelectric130 has a reputation beyond reputeelectric130 has a reputation beyond reputeelectric130 has a reputation beyond reputeelectric130 has a reputation beyond reputeelectric130 has a reputation beyond reputeelectric130 has a reputation beyond repute
Re: amp protection problem. HELP!

Originally Posted by Hippiboy View Post
im running 4 guage for the power and the ground. and 12 guage for the speaker.
what about the ground cable on the battery? stock or upgraded?
electric130 is offline  
Old 06-19-2007
  #8  
Registered!!
iTrader: (1)
 
darklegacy540's Avatar
 
Join Date: Nov 2002
Location: San Diego, CA
Age: 36
Posts: 989
Rep Power: 0
darklegacy540 is on a distinguished road
Re: amp protection problem. HELP!

I would first double check your power and ground connections, as well as the ones on the battery.. then as Chris was saying, meter your voice coils.. If you have a voice coil that's lower than two or four ohms (other than perhaps a .4 ohm +/- tolerance) that's automatically forcing your amp into protection so you don't fry the amp. What makes me think this is because you posted that it only happens when you turn it up.
darklegacy540 is offline  
Related Topics
Thread
Thread Starter
Honda Civic Forum
Replies
Last Post
h4ldol
7th Generation Civic
5
04-24-2017 09:16 PM
UltraHDGames
Member's Rides
13
06-08-2016 06:16 PM
carid
Parts and Products
0
09-28-2015 11:13 AM
mnewcomb
Air Conditioning
2
09-27-2015 12:02 AM
260000milesgoal
I.C.E. (Audio) & Electrical Upgrades
2
09-25-2015 08:41 PM


Thread Tools
Search this Thread
Quick Reply: amp protection problem. HELP!


Contact Us Archive Advertising Cookie Policy Privacy Statement Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.