car turns off in drive or reverse but not in parking or neutral!! - Honda Civic Forum



1st - 5th Generation Civic In the years from 1973 to 1995 Honda released it's 1-5th Generation Civics

Reply
 
 
 
LinkBack Thread Tools Search this Thread
Old 08-03-2009   #1
Registered!!
Thread Starter
 
Join Date: Aug 2009
Posts: 2
Rep Power: 0
921.6vtec is an unknown quantity at this point
Cool car turns off in drive or reverse but not in parking or neutral!!

I have a 1992 Honda civic dx with a 1.6 vtec engine i swapped into it, I was having 2 problems the first one was it would loose acceleration and then get it back again while running and the problem was my o2 sensor, that is fixed but now i have another problem i dont know what it can be? any help will be greatly appreciated. This happens not all the time but mostly when the car is warmed up and used for at least 30 min. The car is running good with power but when i get to a red light and just idle in drive the car starts shaking as it tries to stay on but it just dies most of the time and this happens in drive or in reverse, so for this not to happen i have to put the car in parking or in neutral when i stop completely in a red light and the car just stays on without no problem and after it dies it turns back on without a problem every time but its getting me frustrated because i cannot find what is the problem i changed the distributor, iacv, computer and map sensor from a car that has no problem, brand new spark plug cables (even upgraded to some better ones), and spark plugs. Throtle body,fuel injectors, and fuel pump from the junk yard and the problem is still there. sorry for making this so long just trying to give as much info as possible so i can get better help any answers will be helpful
921.6vtec is offline   Reply With Quote
Old 04-20-2010   #2
Registered!!
 
Join Date: Apr 2010
Posts: 3
Rep Power: 0
zavnet is an unknown quantity at this point
Re: car turns off in drive or reverse but not in parking or neutral!!

Quote:
Originally Posted by 921.6vtec View Post
I have a 1992 Honda civic dx with a 1.6 vtec engine i swapped into it, I was having 2 problems the first one was it would loose acceleration and then get it back again while running and the problem was my o2 sensor, that is fixed but now i have another problem i dont know what it can be? any help will be greatly appreciated. This happens not all the time but mostly when the car is warmed up and used for at least 30 min. The car is running good with power but when i get to a red light and just idle in drive the car starts shaking as it tries to stay on but it just dies most of the time and this happens in drive or in reverse, so for this not to happen i have to put the car in parking or in neutral when i stop completely in a red light and the car just stays on without no problem and after it dies it turns back on without a problem every time but its getting me frustrated because i cannot find what is the problem i changed the distributor, iacv, computer and map sensor from a car that has no problem, brand new spark plug cables (even upgraded to some better ones), and spark plugs. Throtle body,fuel injectors, and fuel pump from the junk yard and the problem is still there. sorry for making this so long just trying to give as much info as possible so i can get better help any answers will be helpful
could someone help this dude .. i am having the same problem.... the dat eis 2009 august .. did u find a solution?
zavnet is offline   Reply With Quote
Old 04-21-2010   #3
Registered!!
Thread Starter
 
Join Date: Aug 2009
Posts: 2
Rep Power: 0
921.6vtec is an unknown quantity at this point
Wink Re: car turns off in drive or reverse but not in parking or neutral!!

no i ended up selling the car but then a mechanic told me that it was the brake booster. He said that is a common problem in the honda but i never had the chance to try it but you can go ahead and try it maybe that will fix your problem just let me know what your solution is so i can know.
921.6vtec is offline   Reply With Quote
Old 04-23-2010   #4
Registered!!
 
Join Date: Apr 2010
Posts: 3
Rep Power: 0
zavnet is an unknown quantity at this point
Re: car turns off in drive or reverse but not in parking or neutral!!

Quote:
Originally Posted by 921.6vtec View Post
no i ended up selling the car but then a mechanic told me that it was the brake booster. He said that is a common problem in the honda but i never had the chance to try it but you can go ahead and try it maybe that will fix your problem just let me know what your solution is so i can know.
i believe this is the exact problem that i am having and is about to try this ... i will give that a look also

the Torque Converter Clutch (tcc) not dis-engaging when coming to a stop .. yes it could be the brake stop light switch not sending any signal to disengage he clutch....either way the clutch is suppose to disengage when going to like 6kmh.. it doesn't hence stalling the car also .. this was internet research which matches up to the problem that i have.

see the link below best one i have come across

http://www.montecarloss.com/TCC_Solenoid.html


so by the way r u saying that u sold the car with the problem? lol
zavnet is offline   Reply With Quote
Old 04-23-2010   #5
Registered!!
 
Join Date: Jul 2009
Posts: 605
Rep Power: 0
Awjvail is an unknown quantity at this point
Re: car turns off in drive or reverse but not in parking or neutral!!

So did you not think it could be a problem with the transmission when you were changing everything else?

Think of it as a manual transmission and you left your foot off the clutch.. when you stop with the car in gear, the car is going to stall. If you stop with the car in neutral and your foot off the clutch, the car won't stall. If you leave the car in gear and push the clutch it when you stop, the car will not stall.

Something is wrong with the automatic transmission clutch(es).
Awjvail is offline   Reply With Quote
Old 04-23-2010   #6
Registered!!
 
Join Date: Apr 2010
Posts: 10
Rep Power: 0
oldskool89 is an unknown quantity at this point
Re: car turns off in drive or reverse but not in parking or neutral!!

That's so weird I wouldn't have guessed the booster would be at fault right away.. My first reaction would've been that MAP sensor.. This is really helpful for me also..

There's alotta stuff that u learn from here lol.
oldskool89 is offline   Reply With Quote
Old 04-28-2010   #7
Registered!!
 
Join Date: Apr 2010
Posts: 3
Rep Power: 0
zavnet is an unknown quantity at this point
Re: car turns off in drive or reverse but not in parking or neutral!!

Quote:
Originally Posted by Awjvail View Post
So did you not think it could be a problem with the transmission when you were changing everything else?

Think of it as a manual transmission and you left your foot off the clutch.. when you stop with the car in gear, the car is going to stall. If you stop with the car in neutral and your foot off the clutch, the car won't stall. If you leave the car in gear and push the clutch it when you stop, the car will not stall.

Something is wrong with the automatic transmission clutch(es).
PROBLEM FIXED !!!... Well the link above did not help me because i took out the the valve body and replaced it completely and still had the problem . the transmission guy blamed the electrician who wired the car so i went to another electrician who also blamed the transmission ... so my bro and i got upset and got rid of the transmission all together and bought another one and yup it worked. no more problem that trany that i had was total garbage and to think i just bought it to do the swap and ended up having to buy another.
zavnet is offline   Reply With Quote
Old 10-03-2015   #8
Registered!!
 
Join Date: Oct 2015
Age: 27
Posts: 1
Rep Power: 0
Cotie is an unknown quantity at this point
Re: car turns off in drive or reverse but not in parking or neutral!!

I'm having this same problem and I changed the tranni and it still does the same thing
Cotie is offline   Reply With Quote
Old 04-07-2017   #9
Registered!!
 
Join Date: Apr 2017
Age: 21
Posts: 1
Rep Power: 0
Mario Moreno is an unknown quantity at this point
Re: car turns off in drive or reverse but not in parking or neutral!!

Quote:
Originally Posted by Cotie View Post
I'm having this same problem and I changed the tranni and it still does the same thing
So what happened? They barley called me to fix some like this on a ford ecoline E150 I'm about to check the transmission torque converter the break light switch and break booster
Mario Moreno is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Honda Civic Forum Replies Last Post
Honda Civic 99 Care ChristinaVHH 6th Generation Civic 2 05-10-2015 04:51 PM
crank no start Trav_02civic Mechanical Problems/Vehicle Issues and Fix-it Forum 3 04-23-2015 09:57 AM
06 Civic EX Not Starting - Any Suggestions SSMatey Mechanical Problems/Vehicle Issues and Fix-it Forum 4 04-13-2015 07:09 PM
apexi n1 exhaust sound? 01civicboi Basic Engine Performance 0 11-02-2001 08:33 AM


Tags
98, car, civic, drive, enghine, honda, light, parking, problems, put, reverse, shuts, starts, stop, turns

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -5. The time now is 01:23 AM.


All Content Copyright 2017 CivicForums.com We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.