Go Back   Honda Civic Forum > GENERAL > Electrical, Wiring, and In Car Entertainment
Register Forgot Password?
Register Photo Gallery FAQ Members List Search Today's Posts Mark Forums Read Experience Used CarsGarageVendor Directory
Welcome to Honda Civic Forum

Electrical, Wiring, and In Car Entertainment Electrical, Wiring and In Car Entertainment questions belong here.


Reply
 
 
 
 
LinkBack Thread Tools Search this Thread
Old 10-12-2011   #1 (permalink)
Registered!!

 
Join Date: Oct 2011
Posts: 1
Points: 31, Level: 1
Points: 31, Level: 1 Points: 31, Level: 1 Points: 31, Level: 1
Level up: 62%, 19 Points needed
Level up: 62% Level up: 62% Level up: 62%
Activity: 1.6%
Activity: 1.6% Activity: 1.6% Activity: 1.6%
iTrader: (0)
Rep Power: 0
mausimo is an unknown quantity at this point
2007 Civic SI Stereo has no power

Hey,

My car is a 2007 Honda Civic SI.

A little while ago I get into my car and stereo has no power. The display will not even turn on. I checked all the appropriate fuses, still no power.

I unplugged the battery and let it sit (to drain memory). Hooked the battery back up and turned on the car and the stereo works.

A few hours later, I get back into my car and stereo is once again dead. Hitting the power button has no effect and display will not turn on. Once again i unplugged the battery and let it sit. Hooked the battery back up and turned on the car and the stereo works.

WTF? Any Ideas?

It will always power on after disconnecting the battery and reconnecting it.

-Mike

Last edited by mausimo; 10-12-2011 at 02:38 PM.
mausimo is offline   Reply With Quote
Old 12-08-2011   #2 (permalink)
Registered!!

 
Join Date: Dec 2011
Posts: 1
Points: 30, Level: 1
Points: 30, Level: 1 Points: 30, Level: 1 Points: 30, Level: 1
Level up: 60%, 20 Points needed
Level up: 60% Level up: 60% Level up: 60%
Activity: 0.6%
Activity: 0.6% Activity: 0.6% Activity: 0.6%
iTrader: (0)
Rep Power: 0
cwailes09 is an unknown quantity at this point
Re: 2007 Civic SI Stereo has no power

Today I just experienced this same problem. I'll let you know what I find when I figure it out.


Ok, So I figured out there is a fuse labeled "Back-up" underneath the hood, which if blown affects multiple items (anti-theft, radio, key fob), Tested the fuse, found it was blown. Replaced and all problems seemed to be fixed at the moment!!!

Last edited by cwailes09; 12-08-2011 at 09:58 AM. Reason: New information
cwailes09 is offline   Reply With Quote
Old 12-08-2011
CivicForums
Honda Civic




Paid Advertisement
 
 
 
Reply


Tags
07 , 2007 , amplifier , audio , car , civic , dead , display , fuse , honda , on , power , radio , si , stereo

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

  
User Login
Our Partners


used new
Top 10 Threads
What a good average amount of watts for a subwoofer?
Changing Battery Question
Post pictures of your trunk speakers!
How do I replace this fuse?
blinking red light???
trunk pop lock, seat lock, and trunk lock wont open...
Faulty Alarm after flat battery
Battery charger: reverse polarity damage?
cd player memory wire not working
Amp Cooling Fan?


All times are GMT -5. The time now is 03:51 PM.

   
Advertising - Privacy Statement - Terms of Service - Jobs
Powered by vBulletin® Version 3.7.5
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO 3.5.2
All Content Copyright 2007 CivicForums.com
Emails Backup